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Summary 
Most people who write a lengthy report in Microsoft Word for the first time know how difficult it is – one has 
to number the pages, label all the figures and tables, and so on. There are seemingly endless hoops to jump 
through in order to make sure that your page numbering is correct, and to make sure all your figures and tables 
are numbered properly, making sure all your references are in order and correct, and so on.  
 
However, there are a number of ways around this. Assuming you don’t want to learn LaTeX, or any other 
advanced tool for typesetting, there are still a number of ways to get Microsoft Word to behave nicely. 
 
Report writing is a huge chore as it is – and there are a number of ways that you can make Word do a lot of 
things for you. This guide will show you how to write a report using Microsoft Word while keeping yourself 
sane.  
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1 Introduction 

1.1 Purpose 

The purpose of this document is to provide a quick guide to how to use the features in Microsoft Word to 
make report writing easier. This document hopes to familiarize the reader with aspects of Microsoft Word’s 
referencing capabilities so that the reader does not eventually go insane keeping track of all the numbers that 
will inevitably result by a report.  

1.2 Scope 

This manual is written for someone with reasonable computing background and at least familiar with aspects 
of Microsoft Word. Therefore, you should know how to type, and terms like menu, toolbars, etc. are assumed 
to be familiar to the reader. This document assumes that you know how to turn on a Windows-based (or Mac-
based) computer and use it. So you know how to click, drag, and select items using a mouse.  

1.3 This is a guide – not a manual!  

This is not a manual, but a guide to how you would go about and use some of the cool features provided by 
Microsoft Word. This is definitely not a thorough manual of any description, and should not be treated as such. 
There are step-by-step instructions on how to do most things, so you can skip right to them if you want. 
However, it’s usually nice to know why you’re doing something as opposed to just doing it.  

1.4 Version used 

This document was written for and using Microsoft Office 2003, and thus the screens displayed or locations of 
features may differ from what you see in the screenshots in this guide. From experience, Office XP is pretty 
similar to 2003, but Office 2000 will differ a lot. If you’re using Office 95 or 97… uhhhhh… – please save 
your sanity by upgrading to one of the newer Offices.   
 
This document should apply to a Macintosh computer using Office X, but I can’t guarantee that.  

1.5 F1 – Help! 

The F1 button – the universal help button in Windows programs – is your friend. Use it if there are things you 
don’t know how to do or if this guide isn’t clear. It doesn’t bite, hurt, or cost you any money (okay, 
technically it does, but you’ve paid for it already, so you might as well use it). If you have a fear of little 
animated paperclips, that’s understandable, and I assure you you’re not alone. It can actually be turned off 
fairly easily, but that is beyond the scope of this document. You can press F1 to find out how to turn it off. ☺ 

1.6 Improvements to this document 

Improvements to this document are always welcome. If you have any suggestions about how this guide can be 
improved or anything that could be added, please feel free to email me at the email address listed on the title 
page of this guide. Please don’t spam – spam isn’t good.   
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1.7 Why this was written 

This document started while I was a teaching assistant for GenE 167 (Introduction to Methods of Electrical 
and Computer Engineering), during the Fall 2004 term. At the time, there was a 20-page report that was due, 
and it shocked me when I looked at many peoples’ documents that people were doing their table of contents 
manually. Upon closer inspection, I discovered that not only that, everything else was done manually too!  
 
This was intended to be done in time so that the Class of 2009 could use it for their first work term report. 
However, this document got put on the backburner amid all the marking that had to be done, and I never had a 
chance to finish it until the end of my Winter 2005 academic term.  
 
Hopefully, this document will be a useful guide to students at the University of Waterloo and other 
schools/universities to help them with their reports. 

1.8 A note about the audience 

Note that because this report is written specifically with University of Waterloo ECE Department students in 
mind, there will be some department-specific references in the report. These will be clearly highlighted. The 
concepts and tips in this report, however, should be relevant to anyone who is writing a report using Microsoft 
Word.   

1.9 A little trivia – and a tip for doing well 

The pile of reports featured in Figure 6-1 as the test image was a picture taken of the GenE 167 reports to be 
marked. They took about 30 to 45 minutes each to mark, and at times they could take up to an hour. Each TA 
was responsible for roughly 74 reports, though the number varied a little bit between TAs. It took a long long 
time to mark.  
 
So the tip: keep your TAs sane. Diagrams are good. Conciseness is good. As much fun as it is to slap a 486 
page tome on your teacher’s/TA’s lap - I’ve done it before, for an A-Level (Year 13) Computing project – 
they probably won’t appreciate having to look at all of it.  
 
Two cliché quotes come to mind: “A picture is worth a thousand words,” and “It’s quality, not quantity.” Both 
very true, albeit very overused.  

1.10 Disclaimer, and other such stuff 

This document is provided to the reader as-is without warranty of any kind. You are permitted to redistribute 
this document provided that the title page remains unchanged, any acknowledgements are not tampered with, 
and that this document is reproduced in its entirety. No monetary gain shall be made as a result of this 
document (i.e. you can’t sell this document).   
 
The author of this document will not be responsible for any injury, death, loss of hair, or any other 
phenomenon natural or otherwise to befall the reader after reading this document. The author will not be 
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responsible for anything that happens to your computer as a result of reading this document, including, but not 
limited to, damage by smashing, lightning, or viruses.  
 
The author also cannot be responsible for anyone failing a course, failing a report, or losing marks due to this 
document – please don’t use “but Jason said so!” as an excuse for not following the guidelines you are 
supposed to follow.  
 
The author has made all reasonable attempts to ensure that the document contains no viruses and will not 
spread viruses to readers’ computers. However, if you obtained this document from someone who doesn’t 
happen to be the author, then, well, that’s slightly dodgier (but read above, I’m still not responsible for it!) 

Jason Pang – Last Updated 26 August 2006 3



Writing a Report using Microsoft Word’s Tools (v1.2.2) 

2 Report Writing Hints and Tips 
Although (in principle) outside the scope of this document, here are some tips and pointers for creating a 
report that reads looks good and reads well. This stuff is good to keep in mind while you’re writing your 
report. 

2.1 General Report Writing 

• Structure your report from the very beginning. Provide an outline first, and then fill in the rest of the 
document according to your outline. Your brain and the person reading your report will thank you for 
it.  

• Spell check and proofread! This may sound hypocritical since this document hasn’t been proofread by 
someone else, but it’s important for a quality report. 

• Get someone else to proofread it for you – you’ll be amazed at all the problems you didn’t catch.  
• Months should be spelled out to avoid confusion, i.e. “8 October 2004” instead of “8/10/04.” 

Alternatively, use the unambiguous short form, “Year-Month-Day” format, i.e. “2004-10-22.” 
• Use one consistent date format throughout your report.  

 

2.2 Style 

• Make your top-level headings a large size (in this document, they’re 16pt). Make your 2nd-level 
headings at least 3 point sizes smaller than the top-level heading.  

• In general, a document reads better if you use sans-serif fonts (e.g. Arial, Helvetica, Tahoma) for 
headings, and serif fonts (e.g. Times New Roman, Georgia) for the main body.  

• Use consistent fonts. Fonts should not abruptly change in the report. For example, use one font and 
size for headings, one for the main body, one for captions, etc. Word generally does a good job of 
doing this for you if you don’t change anything too drastically.  

• Comic Sans MS is an evil font. Using it turns your otherwise brilliant report into something little 
more than a comic strip without pictures. It also isn’t as pleasing to the eye as fonts like Helvetica.  

• 1.5 spacing is generally a good spacing to make a report readable. You can actually get away with 1.3 
in most cases, and it’ll still be relatively readable. Make sure it doesn’t violate the rules that govern 
your particular report, though.  

• If you need more space, decrease the margins of the page (File → Page Setup). Again, ensure it 
doesn’t violate any rules governing your report.  

• Leave a new line between paragraphs if they are not indented.  
• The referencing style used in this document is the January 2004 edition of the Computer Society Style 

Guide [2]. You may follow the style used in your textbook or the one used in this document – both are 
valid for the purposes of a GenE 167 report (as of Fall 2004).  
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• Consistency is key! For example, in this list, you see that all the ends of sentences have periods. 
Others in this document do not. This is bad style – stick to one convention, and don’t deviate. 
Similarly, table entries should either all have periods, or not.   

• There should never, ever be a report section titled “Report Body.” That’s just plain wrong.  
• There should not be a “Table of Contents” entry in the Table of Contents.  

2.3 Spell checkers and grammar checkers 

• The grammar checker isn’t the smartest thing on the planet. Consider this sentence:  
Ann, while Bob had had "had," had had "had had". "Had had" had had a better effect on the teacher. 
It is a perfectly valid sentence, but will probably warp the average reader’s brain. In this case, let’s say 
that “had” and “had had” are answers to some kind of test.  
Ann, while Bob answered “had,” had answered “had had.” The teacher liked “had had” better as an 
answer.   
The grammar checker will not see a problem (it’s a correct sentence) but it takes way too much effort 
to make sense of. (Thanks to my high school computing teacher, Dr. Checkland, for this) 

• Spell checkers are also not foolproof.  
• But use the spelling and grammar checkers! It will help you reduce the number of spelling and 

grammatical errors. It is no substitute for having a person read it.  

2.4 General tips and hints 

• Save, save, and save often. Put a copy on your Nexus account, and email it to yourself once in a while.  
“At the end of every day, I put a copy in my GMail. So at worst, I’m only out one day’s work.” – Jeff 
Zarnett, CompEng 2009. 

• Whoever is proofreading your report should never be the first to read your report. I’m not kidding – 
people have given me reports that they have obviously not read themselves. A strip from Calvin and 
Hobbes comes to mind (Calvin tries to gets his future self to write his book report for him):  
Mom: So is the report done or not?  
Calvin: Oh it’s done. I just haven’t read it.  

• Print it out, look over it in print form before binding it and handing it in. There are an amazing 
number of problems you can catch. 

2.5 University of Waterloo ECE Department tip  

ECE Department work term report checklist guidelines specifically state that the report must not “read like a 
manual.” If your report looks anything similar to this, (i.e. step-by-step instructions), then you will definitely 
fail a work term report for the ECE Department.  
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3 Setting up the Environment 

3.1 Why bother?  

In order to make report writing not a huge chore, one must set some settings in Microsoft Word. Ironically, in 
this first step, you will be disabling many of the automatic “features” that claim to make your life easier. 
Features like AutoFormat and AutoCorrect do more damage to your document than good usually, and 
although you might save a bit of time, you lose control over how your document looks. Worse, you lose the 
ability to finely control the numbering of headings and sections in your document.  

3.2 Why do we do this? Aren’t automatic features helpful?  

For example, Word will automatically help you do formatting of bulleted lists. But how many times has a 
bulleted list come up when you didn’t necessarily intend it to? Or it might have made a bold title into a 
heading for no real reason. This will mess up your formatting, but more importantly, it will mess up the cross-
referencing features discussed in Section 6.  

3.3 Disabling Features in Microsoft Word 

1. Open Microsoft Word 
2. Go to Tools → AutoCorrect Options in the menu bar.  

Note: You may be presented only with a partial menu. This can be identified by the double arrows at 
the bottom of the menu, shown in Figure 3-1. In order to expand this menu to show all of its options, 
hover over the double arrows at the bottom of the menu. The menu will then expand to its full size.  

 
 Figure 3-1: Partial Tools Menu 

3. Under the AutoFormat tab, deselect all the options shown in Figure 3-2. 

 
 Figure 3-2: AutoFormat Options 
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4. Next, in the AutoFormat As You Type tab, you should disable all the features listed under Apply As 
You Type. The settings should roughly match the settings shown in Figure 3-3.  

 
 Figure 3-3: AutoFormat As You Type Options 

5. Finally, click the OK button to close the dialog box.  
 
What you just did was to disable some of the more annoying things in Word that will drive you nuts when you 
proceed to prepare a more complicated report. However, despite setting all this up, there will still be times 
when Word tries to be smart. What this means is that you will have to be ever-vigilant to outsmart Word.  

3.4 Setting up your view 

My personal preference is to view the document in “Print Layout.” This is because it allows me to see how 
everything will be laid out on the page when it’s printed, as I go along. As you will find out later in this 
document, Normal mode will be used for some purposes, but not very often.  
 
To go to Print Layout mode, select  
 View → Print Layout 
from the menu. Figure 3-4 shows how to select the Print Layout view.  
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Figure 3-4: Selecting Print Layout view 
 
One useful tool that many people overlook is the ability to view formatting marks in your document. This 
shows where all the spaces in the documents are, page breaks, and any other weird and wonderful formatting 
you have done with your document. This transforms your view of the document from this (Figure 3-5):  

 
Figure 3-5: Print layout view without paragraph marks 
 
To this (Figure 3-6):  

 
Figure 3-6: Print layout view with paragraph marks 
Note the addition of the paragraph marks ¶, the spaces ·, and other information about page breaks now shown. 
There are many other special symbols that they use - that is beyond the scope of this document.  

3.5 The Normal view vs. Print Layout view 

The main difference between the “Print Layout” view and the “Normal” view are how you can see your 
document. As said above, I personally use the “Page Layout” view since it allows me to see exactly how stuff 
will be laid out on the page (see Figure 3-7). However, there are a couple of shortcomings: one of them is that 
you may tend to want to over-manage the page layout so that it’s exactly how you like it. 
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Figure 3-7: Print Layout view 
 
The thing to keep in mind about Word is that it is a digital typesetter – it will try its best to handle all the 
layouts and stuff for you, and you just have to sort of trust it to do so. Micromanaging the thing won’t help, 
and in many cases, it will turn out very badly.  
 
But if you use the Normal view (Figure 3-8), it allows you more of an objective look at the document, without 
much of the fanciness of the “Print Layout” view - for example, headers/footers are hidden. The other thing 
that is useful is that you can see where your page and section breaks are located at a glance.  
 

 
Figure 3-8: Normal view 
 
That being said, I still prefer the “Print Layout” view over “Normal” since things look prettier. 
 

Hint: you may want to use the “Normal” view to do your section breaks and stuff. It’s just easier that 
way.  
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4 Setting up Styles 

4.1 Why bother?  

One of the features in Microsoft Word that many people overlook (or just don’t know about) is the ability to 
define styles that will allow you to keep a consistent look and feel throughout your entire document. For 
example, you can define your “Normal” style which you will use for your main body text, a “Heading 1” for 
your top-level headings, a “Diagrams” style for keeping all text in your diagrams looking consistent, and a 
“Code Snippet” style for making your text look like it came out of Notepad (i.e. mono-spaced, smaller font, 
etc.)  
 
Another way to think about styles is simply to think about formatting your text normally in Word, except 
instead of applying it to only a certain block of text, you’ll be applying it to all similar blocks of text 
throughout your document. For example, if I wanted to change my heading fonts from Arial to Verdana, I can 
change them all in one go by changing the style (assuming all my headings follow the “Heading 1” style)  
 

Point of Interest: All of Word’s formatting is based on styles. If you make something in your document 
bold, it creates a style “bold” style automatically.  

4.2 Setting it all up 

To show the styles in Word, click on the “Styles and Formatting” button on the toolbar. This button looks like 
two letters side by side, and is shown with the red arrow in Figure 4-1.  

 
Figure 4-1: Formatting Toolbar Showing Styles 
 
Your window will now have a toolbar (or “Task Pane,” by Microsoft terminology) on the right hand side, with 
all your current styles shown. Clicking on a style will apply the style to the current paragraph the cursor is on, 
and you can change the style by right-clicking on the style and clicking “Modify.” You can see this in action 
in Figure 4-2.  
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Figure 4-2: Styles Task Pane 
 

Note: The styles can also be accessed as a pull-down menu next to the “Styles and Formatting” button 
(see Figure 4-1).  

 
Now, say I want to change the Heading 2 style from the (boring) Arial font to Tahoma. This can be achieved 
by right-clicking the corresponding style and choosing “Modify” from the menu. This will bring up the dialog 
box shown in Figure 4-3. The intricacies on how to modify fonts and font styles will be left to the reader.  

 
Figure 4-3: Modifying a Heading Style 
 
It is strongly recommended that a style for numbering is set up now. You can do so by clicking on the 
“Numbering” item in the menu shown in Figure 4-3, and then by selecting your favourite numbering style in 
the Numbered tab. This should be done for all the heading styles that are defined in your document.  
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4.3 Defining a style of your own 

Now that you’ve learnt how to do styles and what they’re all about, it’s time to define your own – a Heading 1 
style that is not numbered. It will be useful when you need to make your Table of Contents headings.  
 
In order to do this,  

1. Click on the “New Style” button (above the listing of styles). 
2. Make the new style “based on” (third drop-down box from the top in the dialog box) Heading 1 - see 

Figure 4-3.  
3. Disable the numbering (Format → Numbering).  
4. Give the new style a meaningful name. 
5. Set it up so that the “Style for the following paragraph” is Normal.  

4.4 Using your styles 

Using your styles is very easy. Just select the paragraph you wish to apply the style to, and click on the 
corresponding style in the toolbar on the right.  
 

Note: It is imperative that you consistently label your major headings as “Heading 1” and your minor 
headings as “Heading 2” or “Heading 3.” It will become apparent when you do your table of contents 
(Chapter 7) why you need to do so.  

 
Congratulations! You have just learnt the basics of how to do styles!  
 
Right now, this stuff seems like unnecessary overhead – especially when you’re trying to get to actual work 
doing your report. However, this will all pay off in the end, I promise.  
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5 Splitting Sections 

5.1 Why bother?  

One of the major annoyances when writing a report is the need to number your pages in the front matter using 
Roman numerals, while everything else in the body is numbered normally – oh wait, the numbering has to 
restart from 1 too! Furthermore, some pages must not be numbered and some pages must be numbered but not 
show it on the page!  
 
In my term as a TA, I have seen various weird and wonderful ways of getting around this problem. For 
example, front matter and body material are kept in separate files, and the title page and letter of submittal is 
kept in yet another file in order to keep the numbering straight. The table of contents are done manually, as 
are the list of tables and figures – a right pain if you have more than a handful of tables and figures. Another 
method was to do all the numbering by hand in the form of text boxes.  
 

Aside: one of the more interesting solutions to the problem I’ve seen is page numbers being printed out, 
then (physically) cut and pasted into the document, and the resulting document photocopied. So each 
page looked like it had a printed page number, but in fact the person had spent hours (probably) putting 
the numbers in. The only part that gave it away was that one of the page numbers was half-folded when 
it was copied, so I saw the shadow plus the awkwardly covered number.  

 

5.2 Solving the problem - Sections 

Okay, so we want to obviously avoid this source of pain. What can we do? The answer to this lies in the form 
of Sections in Word. Each section can (among other things) have its numbering completely independent of the 
preceding section, and its headers and footers can also be different for each section.  
 

Hint: You may want to temporarily switch to “Normal” view while you do your sectioning. It’s just 
easier that way. (On the menu: View → Normal) 

5.3 Show me how! 

Let’s say we’re writing a typical work term report, and it requires the front matter to have a different page 
numbering scheme, and a different header and footer than the main body of the report. In order to do this, 
these steps should be followed. This assumes that you already have some kind of content in your first section:  
 

1. Move to the end of your front matter.  
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2. Instead of making a new page for the new “section,” select Insert → Break… from the menu bar. You 
will see a dialog box similar to the one shown in Figure 5-1.  

 
 Figure 5-1: Selecting a break type 

3. Under “Section break types,” select “Next page.”  
Note: You can experiment with the other types of breaks more when you have time. For almost all 
intents and purposes, a “Next page” break is suitable.  

4. You will get a new page. 
This seems unremarkable at first: a new page has been created. Hooray. But on closer inspection, you 
will notice something different: the section number (shown circled in red in Figure 5-2) is now 2. If 
you click back on the first page, you will find that the section number is 1.  

 
 Figure 5-2: A new section number 
Now, let’s insert page numbers into each section. 

1. Go to your previous section.  
2. Select Insert → Page Number from the menu bar. 
3. You will be shown a dialog box like the one shown in Figure 5-3.  

 
 Figure 5-3: Inserting page numbers 
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4. Click OK. The first section will have page numbers inserted.  
5. Go to your new section, and select Insert → Page Number from the menu bar again.  
6. This time, instead of clicking OK, click Format... 
7. You will see a dialog box shown like in Figure 5-4. Notice the drop down list (highlighted as a 1) in 

the figure. This box allows you to select a numbering style for the current section.  
8. However, note item 2 in Figure 5-4. It allows you to “Continue [page numbering] from previous 

section” or “Start at:” – this allows you to set up a new section’s numbering system!  

 
 Figure 5-4: Page Number Format dialog box 

9. Select a different numbering system, and “Start at” 1.  
10. Now, notice that the two sections have page numbers that are independent.  

5.4 Headers and Footers in Sections  

Another thing that can be done with sections is the ability to have different headers and footers for each 
section.  
 
Recall: Headers and footers are bits of text (or anything, for that matter) that appear at the top and bottom 
(respectively) of every page. 
 
To modify your headers and footers, select View → Header and Footer from the menu bar. Alternatively, if 
you have already defined headers and/or footers, double-clicking on the header or footer will allow you to edit 
it.  
 
Once you’re editing the header and footer, you will see the Header and Footer toolbar, and you will be able to 
change the text in your headers and footers. There are a few things that I would like to highlight that are 
special to headers and footers in sections, shown below in Figure 5-5.  
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Figure 5-5: Editing Headers and Footers 

1. Shows which section’s header/footer you are working with, 
2. Shows whether or not the current section’s headers/footers are the same as the headers/footers of the 

previous section, 
3. Button toggling between linking the headers of the previous section and un-linking.  

 
If this section’s header/footer is not “Linked to Previous,” then you can change your header and footer for this 
section. And that’s it! You’ve learnt how to use sections to your advantage! 
 
Remember: page numbering inserted by using Insert → Page Numbers… is just another element in the header 
or footer. If you unlink it (i.e. disable “same as previous”) then you can delete the page numbering from one 
section while keeping it intact in another.  
 

Hint: In case you haven’t figured out where to apply this, think Letter of Submittal and Title Page.  
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6 Captioning Tables and Figures 

6.1 Why bother?  

It’s required for most report style guides (IEEE, APA, etc.) that you have to caption all your tables and figures; 
that is, you must caption all your images with a number and a short description. It’s a huge hassle to keep 
track of the numbers, and an even bigger hassle to make sure that, if you insert an image/figure earlier in your 
document, all the figure numbers following that new figure are updated. Word’s captioning feature can be 
used to keep track of this for you, and you will save yourself a lot of hassle in the end. You can use this 
captioning feature with both tables and figures.  

6.2 Show me how! 

1. Insert the image into your document.  
Tip: You can insert images by clicking and dragging a file into the document, by using Insert → 
Picture from the menu, or by copying your image from your image editing program and pasting it in.  

2. Right click the image, and select “Caption.”  
Sometimes the “Caption” item is not displayed. In this case, you can use  
Insert → Reference → Caption from the menu bar. You can see this step in Figure 6-1. 

 
 Figure 6-1: Selecting the Caption feature 

3. A dialog box will pop up allowing you to select the type of label (Figure, Table, Equation), position 
relative to the captioned item (above/below), and you are also able to select numbering options. It is 
recommended that you check the “Include Chapter Number” option, by clicking on “Numbering,” and 
then selecting the relevant options. 
 
Note: Here is where things should start falling into place about why we defined the Heading 1’s. If 
you notice in Figure 6-2, there is a selection saying “Chapter starts with style.” This means that the 
chapter number (i.e. in this example, the “6” in “Figure 6-2”) is derived from the number of the 
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“Heading 1” preceding the caption.  

 
 Figure 6-2: Changing caption options 

4. Now, change the Caption text. Make sure not to overwrite the label and text, as this is the automatic 
part of the operation. It is recommended that you place a colon immediately after the caption number, 
a space, and then your short description of the image.  

5. If you do not see the label (i.e. Figure / Table / Equation), uncheck the box labelled “Exclude label 
from caption”  

6. Make sure at this point that you have selected the correct type of caption – i.e. selecting Figure, Table, 
or Equation from the drop down box (see Figure 6-2). 

7. Click OK, and you’re done! The caption will appear in the place you selected (above/below)  
 

Note: The IEEE referencing guide requires that tables must have their captions above, and figures 
below [2]. Be sure you have followed this convention (if you’re writing using the IEEE style). 

 
The procedure for captioning tables is similar. It’s recommended that you select the entire table, right click it, 
and then select “Caption.” The procedure then follows exactly the same as that for captioning images. 
However, make sure that you put your caption for your table in the correct place! 
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Figure 6-3: Captioning a table 

6.3 That’s great… who cares?  

Nothing remarkable has happened yet. You have captioned an image or table, and the numbers are static 
anyway. The magic happens when you try to add a figure before the last figure. If you add a figure before the 
last figure, you will notice that the numbering will be automatically updated for all the following figures!  
 

Note: Okay, sometimes it’s not quite as automatic as that. You may have to select the entire document, 
and then press F9 to update all the captions.  

 
And that’s it!  
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7 Cross Referencing Features 

7.1 Why bother? … I mean, why did I bother?  

So we’ve meticulously numbered everything from the headings to the figures to the tables. Who cares? It 
seems like we did an awful lot of work for almost nothing. We’ve numbered our pages correctly, and we’ve 
defined a whole bunch of styles.  
 
Here is where the fun begins, though. Word’s cross-referencing features are truly amazing, in that they are 
(basically) fully automatic! In this chapter we’ll step through how to cross-reference material in the document. 
And it’s actually a lot simpler than it seems.  

7.2 Cross-referencing things 

So let’s say we need to refer to an image from before, say Figure 6-3. These are the steps that you need to 
follow:  

1. On the menu bar, select Insert → Reference → Cross-reference.  
2. A dialog box similar to the one you see in Figure 7-2 below will appear. 

 
 Figure 7-1: Cross-reference dialog box 

3. And here is where the fun begins. You can now select between headings, tables, figures, endnotes, etc. 
to cross reference. So if you wanted to cross-reference a figure, you would select “Figure” from the 
drop down box shown in Figure 7-1. If you wanted to reference the section number, you would select 
“Heading” from the drop down box.  
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4. Let’s say we wanted to reference a figure. Figure 7-2 below shows an example of the numbered items 
available for you to reference (the list is actually from this document).  

 
 Figure 7-2: Cross-reference dialog box for figures 

5. Click on the figure you want to cross-reference. 
6. You will probably want to change the “Insert reference to” drop-down box to “Only label and 

number.” 
 Table 7-1: Result of different types of referencing 

Insert reference to: Result of referencing Figure 7-2
Entire caption Figure 7-2: Cross-reference dialog box for figures
Only label and number  Figure 7-2
Only caption text Cross-reference dialog box for figures
Page number 21
Above / below above (Useful if you want to refer to the “figure above”) 

 
7. And that’s it! You’ve made a reference to another object! Now, if the order of the figures changes, 

you the caption will be updated automatically to reflect the change in numbering.  
 

Note: In order to insert a cross-reference to anything, the figure has to be in the document and captioned 
already. Therefore you have to insert your images/tables before you caption, and make sure you refer to 
the table by number in the text before it appears.  

 
You’ll probably have to play around with all the different things you can do with this tool in order to fully 
grasp everything that can be done.   

7.3 What else can I do? Table of Contents and more 

One of the great pain-in-the-behinds (if you didn’t do your numbering and things correctly, that is) is the fact 
that you need to create a table of contents, list of figures, and list of tables. But now, with our newly learnt 
referencing capabilities, we can get Word to do this for us!  
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1. Go to where you want your Table of Contents in your document.  
2. From the menu, select Insert → Reference → Index and Tables… as shown in Figure 7-3. 

 
 Figure 7-3: Selecting Index and Tables 

3. A dialog box like the one shown in Figure 7-4 will be displayed.  

 
 Figure 7-4: Creating a Table of Contents 

4. Select the Table of Contents tab. 
There should not be anything else you need to modify. However, if you have spare time, you can play 
around with the many settings that are available to you through this dialog box.  

5. Click OK. Your table of contents will be inserted! 
 
That really is all there is to it. You can repeat the steps above to get a list of figures and list of tables inserted.  
You will find that sometimes, page numbers do not get updated automatically after inserting a new figure. 
When this happens, this is what needs to be done:  

1. Select everything in the document (press Ctrl + A, or from the menu: Edit → Select All)  
2. Press F9.  
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3. A dialog box may appear like the one in Figure 7-5.  

 
 Figure 7-5: Updating Table of Contents 

4. For each one of them that shows up, select “Update entire table.”  
 
Occasionally you will encounter the text: “Error! Reference source not found” in your document. This 
means that the image or table that you referenced was deleted, and therefore no reference to it can exist any 
more. You should check your document for these errors before printing out your final copy to ensure you’re 
not left with embarrassing reference not found errors in your document.  
 
You can do a regular search (by selecting Edit → Find from the menu) for this text to see any errors resulting 
from deleted references.  
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8 References 

8.1 References: why are they important?  

Finally, we get to one of the most important aspects of a report: references. While in some cases there really is 
no need to cite other material, this would be in the rarest of cases. In most other cases, you’ll need to be citing 
other documents in your work, whether it is other technical papers, journals, books, or websites. Not citing 
your sources can also land you in some serious trouble, and many institutions, such as the University of 
Waterloo, have strict policies to deal with plagiarism [1].  
 

Note: This document is written primarily with University of Waterloo students in mind. In any case, at 
any school or university, plagiarism is a big no-no and one must take care to ensure that other peoples’ 
work is properly acknowledged. The relevant policy for the University of Waterloo is Policy 71, which 
can be found at http://www.adm.uwaterloo.ca/infosec/Policies/policy71.htm  

 
Note: The referencing style used for this document is based on the IEEE Computer Society style guide 
[2]. Another popular style used is APA [3], which will have a different referencing style.  

8.2 Referencing in Word 

A little-known method for referencing documents in Word is to hack around with footnotes. This way, Word 
will keep track of the footnotes for you, and you have to worry a lot less about keeping them in order and 
making sure they appear (numerically) in order in the document. There may be a more elegant way to achieve 
this, but I haven’t found it yet.  

8.3 Setting it all up 

Unfortunately, referencing isn’t something that Word does very well, so a bit of set up and tweaking is 
required to get it to do what we want it to do. Hopefully by now, you know how to set up sections in your 
document (see Section 5). In order to follow the IEEE format, references need to appear before any of your 
appendices. Therefore, if you want to include any appendices, you should create a new section for them now, 
before starting to do your references.  
 

1. Once you’ve set up your new section, we can now add our first reference. You will want to create a 
new page by pressing Ctrl + Enter. This will give you a new page to work with.  

2. Next, using your style created in Section 4.3, create the “References” heading, and press Enter after 
typing that.  
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3. Here comes the fun part – you will now add your first reference! First of all, go to the place where 
you want to insert your reference.  

4. From the menu, select Insert → Reference → Footnote. The window shown in Figure 8-1 will appear.  

 
 Figure 8-1: Footnote and Endnote window 

5. You will want to select “Endnotes” for the Location, and then select “End of section.”  
6. The rest of the settings should be defaulted to those shown in Figure 8-1. If not, set these settings.  
7. Click Insert. You will now have something that looks like the following.  

Figure 8-2 shows the document body after inserting your first footnote. Figure 8-3 shows the 
references section after inserting the footnote. 

 
 Figure 8-2: Document body after inserting reference 
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 Figure 8-3: References section after inserting reference 

8. You will notice that there are a couple of things wrong with this. First of all, the reference numbers 
are superscripted – this is not allowed by the IEEE style guide. We need to change that by using the 
Styles and Formatting bar on the right hand side (See Section 4.2). 

a. Select the reference number in the References section (the little “1” in Figure 8-3).  
b. The top box Styles and Formatting bar on the right hand side should now read “Endnote 

Reference” 
c. Change that style (see Section 3.5) so that it is not longer superscript.  

9. The second thing wrong with this document is that there is a line appearing underneath the 
“References” heading. This needs to be removed.  

a. Select View → Normal from the menu bar (see Section 3.4) 
b. Now, select View → Footnotes from the menu bar.  

Your screen will now be split into two parts – the bottom part will look something like what 
is seen in Figure 8-4. 

 
  Figure 8-4: Endnotes screen 

c. From the drop-down box, select Endnote Separator.  
d. Delete the line. Your screen should now look like  

 
  Figure 8-5: Endnotes screen after removing separator line 

10. Now return to the Print Layout view (View → Print Layout). You will now see your references in a 
way that is desired.  
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Congratulations! You have now made your first reference in Word. However, you must be sure that you place 
the square brackets (e.g. [1]) around the numbers in accordance with IEEE style. Now, in your references 
section, you can go and change the text following the number.  
 
Making any subsequent references is much less painful:  

1. From the menu, select Insert → Reference → Footnote. The window shown in Figure 8-1 will appear.  
2. You will want to select “Endnotes” for the Location, and then select “End of section.”  
3. The rest of the settings should be defaulted to those shown in Figure 8-1. If not, set these settings.  
4. Click Insert. The reference will now be inserted. Modify as you need.  

 
Finally, if you need to reference the endnote (remember – a reference is an endnote in Word terminology) 
again, then you can simply follow what you did to reference figure/table captions:  

1. Select Insert → Reference → Cross-reference from the menu bar 
2. Select your Reference type to be “Endnote”  
3. Select the Insert reference to to be “Endnote number”  
4. Click Insert.  

 
Done – you have now created a reference to the endnote (reference). 
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9 SI Units 

9.1 Why bother? 

A pet peeve of many professors is that there is no functionality for producing a half-space in Word.  
 
According to your textbook, Introduction to Professional Engineering (Andrews, Aplevich, Fraser, & Ratz), 
half-spaces are preferred to full spaces when separating the number from the unit. In LaTeX and mathematics 
packages, such as MathType, you can put in the half spaces as required. 
 
However, given that you’re reading this document, you probably don’t know how to use LaTeX or don’t want 
to bother to learn how.  

9.2 A quick how-to 

A quick (but dirty) workaround is to use a subscript to pretend to be half space. Let’s see what the difference 
is in Table 9-1.  
 
Table 9-1: Differences in sentence between using no spaces, half spaces, and full spaces for SI units 
Type Sample sentence 
No space The quick brown fox jumped over the 1A power supply and 3Ω resistor.  
Half-space The quick brown fox jumped over the 1 A power supply and 3 Ω resistor. 
Full space The quick brown fox jumped over the 1 A power supply and 3 Ω resistor. 
 
Although you don’t quite notice it, the half-spaced version is more readable than the full space version 
especially in a long block of text.  
 
The no-space one is plain wrong. Don’t do it.  

9.3 Show me how! 

1. Type the number, variable, or whatever it is before your unit.  
2. Press Ctrl-= to activate the subscript option. You can also type Ctrl-+ to activate the superscript

 option. 
3. Type the space.  
4. Press Ctrl-= or Ctrl=+ again (press what you pressed in Step 2 again). This deactivates the option.  
5. Type the unit.  

 
And that’s it! Nicely half-spaced units – your TAs will thank you for it.  
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10 The End… or is it?  
This concludes the documentation for how to write a report using Microsoft Word’s tools. This is by no means 
an exhaustive manual – there may be better ways around this, but this is the way that I have learnt how to over 
the years writing reports. 
 
If you have any suggestions and/or improvements that can be made to this document, please email me at the 
email address on the front cover of this document. I’d be very glad to hear from you. If you have found this 
document useful, you can also drop me a line – it’s always nice to know that your work is appreciated. ☺  
 
Finally, I’ll present some of the quirks in Word that might drive you nuts in the final two sections. They’re not 
in the appendix because: 

• This is good reading anyway. 
• I’m too lazy to fix the sections to include it as an appendix. 
• This is the fastest way to present the information. 
• I’m tired. 

 
I hope you’ve found this document helpful in preparing your report.  
 
If you have any comments, please email me. My contact information is located on the front cover of this 
document.  
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11 Hints and Tips for using Word 
Sometimes, Word is just… plain weird. Here are some things that you might encounter, and workarounds for 
them:  

• F1, the universal help button, is your friend. Use it. It doesn’t bite, and it doesn’t cost you to use it.  
• Inserting a symbol is not as hard as it seems. By selecting:  

Insert → Symbol from the menu bar, you can easily get the most common symbols that you need.  
• If you have formatted a paragraph like crazy and it’s not behaving properly, use the “Clear 

Formatting” format to return it to a clean state, and re-format accordingly.  
• AutoRecover is good. Set it up by going to Tools → Options…  

Under the “Save” tab, check the box labelled “Save AutoRecover info every…” and set it to save 
every three minutes or so.  

• When making a numbered list, sometimes, when you start the next list, it continues on from the 
previous list. If this happens, right click the number, and click “Restart Numbering.” Similarly, you 
can select “Continue Numbering” in order to continue numbering your items from where your last list 
left off.  

• You can make a new page at any time by hitting Ctrl + Enter.  
• Word, as are most word processing programs, are “digital typesetters.” Treat it as such, believe that 

the thing that will handle your layout, and try not to micromanage everything – for example, exact 
diagram locations. If you micromanage how Word does stuff for you, then it tends to end badly.   

• A quip from Andre Masella, UW Comp Eng 2007:  
I've come to the conclusion that Word and LaTeX are similar in that respect. It's just that LaTeX is a 
wise old man who listens and tries to make suggestions and Word is a community college grad who 
thinks he knows it all. 
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